Setup Failure Codes/PHP not using Apache Filter mode

From Davical
Jump to navigationJump to search

The page identifies a critical configuration problem. DAViCal will not work at all until this is resolved.

On some systems PHP might be installed as an Apache "filter" module.

This restricts the HTTP methods that Apache will accept and although the DAViCal user interface will work, the very methods which are blocked are the ones that DAViCal needs to handle to read and respond to DAV and CalDAV requests.

On Debian and Ubuntu the problematic module is called "libapache2-mod-php5filter" and the correct one is called "libapache2-mod-php5".