Difference between revisions of "FastCGI"

From Davical
Jump to navigationJump to search
 
m
Line 7: Line 7:
  
 
This is required because FastCGI doesn't by default pass the authentication headers to the caldav.php script, and authentication will therefore inevitably fail.
 
This is required because FastCGI doesn't by default pass the authentication headers to the caldav.php script, and authentication will therefore inevitably fail.
 +
 +
You will also need to be running version 0.9.4 or later, which includes specific changes to support the FastCGI authentication variables.  Alternatively you can apply the patch [http://git.catalyst.net.nz/gitweb?p=rscds.git;a=commitdiff;h=83cabf87ceba9430532298a0b774f652fe881d0e here] to 0.9.3.
 +
 +
[[Category:Apache configuration]]

Revision as of 09:23, 23 January 2008

DAViCal can be made to work with fastCGI with a simple alteration to the fastcgi.conf file.

Find the FastCgiConfig directive FastCgiConfig -minProcesses 1 -maxProcesses 10 -singleThreshold 100

Add "-pass-header AUTHORIZATION" to the end

This is required because FastCGI doesn't by default pass the authentication headers to the caldav.php script, and authentication will therefore inevitably fail.

You will also need to be running version 0.9.4 or later, which includes specific changes to support the FastCGI authentication variables. Alternatively you can apply the patch here to 0.9.3.